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Figure 1 - Workflow synoptique du TP : L1C (brut) > Sen2Cor > L2A > Resampling > Subset > NDVI > Export.
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Partie 0 : Rappel - Interaction Signal-Atmosphere
Duree estimee : 15 minutes

Memoire

Verifier Sen2Cor

Lancer SNAP v13

Le signal mesure par le capteur se decompose en deux contributions :

L  = L  (radiance de chemin) + ■ . L  (signal utile)
capteur atm surface

L'objectif de la correction atmospherique est d'estimer et soustraire L  pour isoler L , la grandeuratm surface
physique d'interet. Le processeur Sen2Cor realise cette operation en modelisant les proprietes optiques
de l'atmosphere (epaisseur optique, type d'aerosol, vapeur d'eau).

Avant d'atteindre le capteur MSI de Sentinel-2, le rayonnement solaire reflechi par la surface terrestre
traverse l'atmosphere. Deux phenomenes physiques perturbent le signal :

a) La diffusion de Rayleigh : les molecules d'air (N, O) diffusent le rayonnement proportionnellement a
4 2 2

1/■. Les courtes longueurs d'onde (bleu, 490 nm) sont 16 fois plus diffusees que le rouge (665 nm). C'est
la cause principale de la radiance de chemin (L ).

atm

b) La diffusion de Mie : les aerosols (poussieres, gouttelettes) diffusent le rayonnement de maniere
quasi-independante de la longueur d'onde. Cette composante est variable et depend des conditions
atmospheriques locales.

■  Video de reference : 0-Rappel.mov (30 secondes) - Rappel des concepts physiques fondamentaux

Double-cliquez sur l'icone SNAP Desktop. Verifiez la version dans
Help > About SNAP. Ce TP utilise SNAP 13 (comme dans les videos
de formation).

Menu : Optical > Thematic Land Processing > Sen2Cor Processor.
Version requise : Sen2Cor 2.9.0. Si absent : Tools > Manage
External Tools.

Tools > Options > Performance : allouez 4 Go minimum (8 Go

recommande).

0.1 Le premier obstacle : l'atmosphere

0.3 Verification de l'environnement SNAP

0.2 Le modele de mesure : du Soleil au capteur

1

2

3
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Partie 1 : Correction Atmospherique avec Sen2Cor
Duree estimee : 30 minutes

Onglet Processing

Onglet I/O Parameters

Le produit L1C contient la radiance au sommet de l'atmosphere (TOA - Top of Atmosphere), calibree
radiometriquement et georeferencee, mais non corrigee atmospheriquement.

Sen2Cor est un processeur autonome (standalone) qui convertit les produits L1C en L2A. Comme montre
dans la video de formation, les parametres suivants sont essentiels :

✔  

Parametre

Resolution

Aerosol Type

Mid Latitude

Nb Threads

Scene Option

L2A_GIPP

Valeur

ALL (10m + 20m + 60m)

RURAL

SUMMER

1

Scene only

Par defaut

Justification

Traite toutes les bandes spectrales

Adapte aux zones continentales et rurales

Correspond a la saison d'acquisition

Stabilite (augmenter si machine puissante)

Traitement de la scene complete

Fichier de configuration standard ESA

Menu : File > Open Product. Naviguez vers le dossier de donnees.
Selectionnez MTD_MSIL1C.xml (fichier de metadonnees principal).1 Ouvrir le L1C

Dans le Product Explorer, depliez l'arborescence : Metadata, Index

Codings, Vector Data, Tie-Point Grids, Bands, Masks. Les bandes
B1-B12 + B8A apparaissent, groupees par resolution.

2 Explorer la structure

Double-cliquez sur B4 (Rouge, 665 nm, 10 m). Utilisez l'onglet

Colour Manipulation pour ajuster le contraste. L'onglet Pixel Info
affiche les valeurs spectrales au survol.

3 Premiere visualisation

Conseil : Comme montre dans la video, l'onglet World View permet de situer votre tuile geographiquement.

Selectionnez le produit L1C comme Source Product. Le repertoire de
sortie est configure automatiquement.

Configurez les parametres selon le tableau ci-dessus : Resolution =

ALL, Aerosol = RURAL, Mid Latitude = SUMMER.

■ Video de reference : 1-Correction-Athmospherique-Sen2cor.mov (4 min 14 s) - Demonstration complete
de la procedure

1.1 Importation du produit L1C

1.2 Configuration et execution de Sen2Cor 2.9.0

Chemin SNAP : File > Open Product > selectionner MTD_MSIL1C.xml

Chemin SNAP : Optical > Thematic Land Processing > Sen2Cor Processor

1

2
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3

4

1

2

3

4

5 Annoter

Executer

Interpreter

Ouvrir le L2A

Ouvrir Scatter Plot

Axe X

Axe Y

■ Le produit L2A genere contient un fichier .dim et un dossier .data. Ne deplacez jamais l'un
sans l'autre !

C'est l'etape cruciale de validation scientifique. Le Scatter Plot compare pixel a pixel la meme bande entre
L1C et L2A, demontrant visuellement l'effet de la correction atmospherique.

Menu : Analysis > Scatter Plot.

Bande B2 (Bleu, 490 nm) du produit L1C (TOA).

Bande B2 (Bleu, 490 nm) du produit L2A (BOA).

Tous les points doivent etre sous la diagonale 1:1. Le decalage =
L  soustraite par Sen2Cor. Bande B2 choisie car maximalement

atm

affectee (Rayleigh ~1/4■).

Capturer et annoter : diagonale 1:1, zone de decalage, equation

physique.

Cliquez Run. Duree : 10-20 min selon la machine. Un message
confirme : 'The target product has been created and opened in SNAP
13'.

Le produit L2A (S2A_MSI2A) apparait automatiquement dans le

Product Explorer. Sa structure est identique au L1C mais les valeurs
sont des reflectances de surface (BOA).

1.3 Validation par Scatter Plot

Chemin SNAP : Analysis > Scatter Plot
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Figure 2 - Scatter Plot L1C vs L2A (bande B2). L'offset sous la diagonale prouve la soustraction de L_atm par Sen2Cor.
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✎ Livrable : Capture d'ecran annotee du Scatter Plot L1C vs L2A (bande B2) avec identification
de L_atm.



Parametre

Source Product

Define size by

Reference Band

Upsampling Method

Downsampling Method

Resample on pyramid

Target dimensions

Guide de TP | Sentinel-2 & ESA SNAP

Valeur (video)

S2A_MSI2A

Reference band from source

B2 (10 m)

Nearest (Neighbour)

First

Oui (coche)

10980 x 10980 px

Figure 3 - Harmonisation des grilles multi-resolution vers une grille unique.

Explication

Le produit L2A corrige atmospheriquement

Alignement sur une bande existante

Resolution la plus fine pour ne pas perdre d'information

Conserve les valeurs radiometriques originales

Premier pixel de la maille

Accelere l'affichage par niveaux de zoom

Resolution 10 m sur toute la tuile (100 km)

M232 - Physique du Plasma et de la Teledetection

Dr. Imad Hamdi & Dr. Zada Sara

Page 7

Partie 2 : Reeechantillonnage Geometrique
(Resampling)
Duree estimee : 30 minutes

Comme montre dans la video, l'outil Resampling comporte deux onglets : I/O Parameters et Resampling
Parameters.

Sentinel-2 MSI acquiert 13 bandes a trois resolutions : 10 m (B2, B3, B4, B8), 20 m (B5-B7, B8A, B11,
B12) et 60 m (B1, B9, B10). Ces matrices ont des dimensions differentes : 10980x10980 (10 m),
5490x5490 (20 m) et 1830x1830 (60 m). Il est mathematiquement impossible d'effectuer une algebre
de bandes entre des matrices de tailles differentes.

■  Video de reference : 2-Resampling-sen2-Images.mov (3 min 37 s) - Procedure complete de resampling

2.2 Configuration du Resampling

2.1 Probleme de l'incompatibilite matricielle

Chemin SNAP : Raster > Geometric > Resampling
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1

2

3

4

I/O Parameters

Resampling
Parameters

Executer

Ouvrir Resampling

 5 Sauvegarder
 

■ Le produit reeechantillonne est virtuel (en memoire). Si vous fermez SNAP sans sauvegarder,
tout le traitement est perdu ! Sauvegardez en BEAM-DIMAP (.dim + .data).
✎ Livrable : Capture d'ecran du Product Explorer montrant que toutes les bandes ont la meme
dimension matricielle (10980 x 10980 pixels).

Menu : Raster > Geometric > Resampling. Selectionnez le produit
L2A.

Source : S2A_MSI2A. Le nom cible est genere automatiquement avec

le suffixe _resampled. Format : BEAM-DIMAP.

Cochez By reference band from source product. Selectionnez B2
(10 m). Upsampling : Nearest. Downsampling : First.

Cliquez Run. Message de confirmation : 'The target product has

successfully been created and opened in SNAP 13'.

CRUCIAL : le produitest virtuel ! Sauvegardez immediatementvia
File>Save Product.
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Partie 3 : Decoupe Spatiale (Subset) et Visualisation
RGB
Duree estimee : 30 minutes

Naviguer

Ouvrir RGB

Choisir le profil

Cocher l'option

Comme montre dans la video, avant de decouper,
composition coloree pour identifier la zone d'interet.

il est recommande de visualiser le produit en

Une tuile Sentinel-2 complete couvre 100x100 km et peut depasser 1 Go en memoire. Le Subset (sous-
ensemble) permet de se concentrer sur la zone d'interet (ROI) et d'optimiser les ressources de calcul.

■ Video de reference : 3-Subset-Creation.mp4 / .mov (4 min 37 s) - Creation du sous-ensemble et
composites RGB

Clic droit sur le produit reeechantillonne > Open RGB Image Window.

Dans la boite de dialogue Select RGB-Image Channels, selectionnez

le profil Sentinel 2 MSI Natural Colors. Ce profil assigne
automatiquement : R = B4, G = B3, B = B2.

Cochez 'Store RGB channels as virtual bands' pour eviter de

dupliquer les donnees.

Utilisez la molette pour zoomer. Le panneau de navigation (coin

superieur droit) montre la position dans la tuile complete.

3.1 Justification de la decoupe

3.2 Visualisation RGB prealable

Chemin : Clic droit sur le produit > Open RGB Image Window

1

2

3

4



Guide de TP | Sentinel-2 & ESA SNAP

Figure 4 - Recettes de compositions colorees RGB pour differentes applications thematiques.
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3.3 Creation du Subset
Chemin SNAP : Raster > Subset

 Livrable : Capture d'ecran du subset en couleurs naturelles + statistiques d'une bande.

1 Ouvrir Subset Menu : Raster > Subset.

Onglet Spatial Subset : definissez la zone par coordonnees pixel ou

coordonnees geographiques (lat/lon).
2 Spatial Subset

Onglet Band Subset : ne conservez que les bandes utiles (B2, B3,

B4, B5, B8, B11, B12) pour reduire la taille.
3 Band Subset

4 Valider Cliquez OK. Le sous-ensemble est cree.

Utilisez Analysis > Statistics pour verifier les valeurs de chaque

bande (min, max, moyenne, ecart-type).
5 Verifier les statistiques

6 Sauvegarder Sauvegardez via File > Save Product en BEAM-DIMAP.

✔ Conseil : Comme visible dans la video, les statistiques montrent les plages de valeurs de reflectance pour
chaque bande. Verifiez que les valeurs sont dans [0, 1].
✎
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Figure 5 - Formule NDVI et echelle d'interpretation.
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Partie 4 : Algebre de Bandes - Calcul du NDVI
Duree estimee : 30 minutes

Expression

Statistiques

Ouvrir Band Maths

Nommer la bande

Executer

Palette de couleurs

Le NDVI (Normalized Difference Vegetation Index) exploite le contraste entre le rouge (B4, 665 nm),
fortement absorbe par la chlorophylle, et le proche infrarouge (B8, 842 nm), fortement reflechi par la
structure cellulaire des feuilles.

4.1 Principe physique

4.2 Implementation dans SNAP
Chemin SNAP : Raster > Band Maths

1

2

3

4

5

6

NDVI Surface

Menu : Raster > Band Maths sur le produit subset reeechantillonne.

Target Product : NDVI.

Saisir : (B8 - B4) / (B8 + B4). B8 = PIR (842 nm, 10 m) et B4 = Rouge

(665 nm, 10 m). Les deux bandes sont a 10 m grace au resampling
prealable.

Cliquez OK. La bande NDVI est ajoutee au produit.

Clic droit sur NDVI > Colour Manipulation. Appliquez un degrade :

bleu (eau) > brun (sol nu) > vert (vegetation).

Utilisez Analysis > Statistics pour verifier : valeurs dans [-1, +1],

moyenne attendue entre 0.1 et 0.5 selon le paysage.

Interpretation physique
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< 0

0 - 0.1

0.1 - 0.3

0.3 - 0.6

> 0.6

Eau, neige

Sol nu, roche

Vegetation clairsemee

Vegetation moderee

Vegetation dense

Reflectance PIR < reflectance Rouge

Pas d'activite chlorophyllienne

Faible densite foliaire (LAI < 1)

Cultures, prairies (LAI 1-3)

Forets, cultures irriguees (LAI > 3)

✎ Livrable : 1) Carte NDVI avec palette adaptee. 2) Statistiques (min, max, moyenne, ecart-type).
3) Interpretation thematique de 3 zones identifiees.
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Partie 5 : Automatisation - Graph Builder
Duree estimee : 20 minutes

Ouvrir Graph Builder

Ajouter les noeuds

 
Connecter

Configurer  

Executer  

Sauvegarder le graphe

 Livrable : Capture d'ecran du graphe : Read > Resample > Subset > BandMaths > Write.

Le Graph Builder permet d'enchainer automatiquement plusieurs operateurs dans un pipeline graphique,
exportable en XML et executable en ligne de commande (gpt).

5.1 Principe de l'automatisation

Chemin SNAP : Tools > Graph Builder

1

2

3

4

5

6

Menu : Tools > Graph Builder.

Clic droit > Add Operator : Read > Resample > Subset > BandMaths

> Write

Glissez les fleches entre les sorties et les entrees de chaque
operateur.

Double-cliquez sur chaque noeud pour definir ses parametres.

Cliquez Run. Le pipeline complet s'execute.

File > Save Graph en XML. Reutilisable en ligne de commande : gpt
mon_graphe.xml.

✎
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Partie 6 : Synthese, Export et Rapport
Duree estimee : 15 minutes

GeoTIFF

Image PNG

6.1 Export

6.3 Questions de reflexion

6.2 Bareme du rapport de TP

File > Export > GeoTIFF / PNG

1

2

#

Q1

Q2

Q3

Q4

Q5

Section

Introduction

Partie 1

Partie 2

Partie 3

Partie 4

Conclusion

Contenu attendu

Objectif, donnees (satellite, date, tuile), logiciel

Correction atmospherique : Scatter Plot annote + equation physique

Resampling : justification + preuve (dimensions matricielles)

Subset + 2 compositions RGB comparees

NDVI : carte + stats + interpretation de 3 zones

Synthese, limites de l'approche, perspectives

TOTAL

Question

Pourquoi la bande B2 (Bleu) montre-t-elle le decalage le plus important dans le Scatter Plot ?

Que se passerait-il si l'on calculait le NDVI directement sur le produit L1C (sans correction) ?

Pourquoi choisit-on Nearest Neighbour pour le resampling en teledetection quantitative ?

Quel indice spectral utiliseriez-vous pour cartographier les surfaces en eau ? Proposez la formule.

Quels sont les avantages du Graph Builder pour le traitement de series temporelles Sentinel-2 ?

Pts

2

5

3

3

5

2

20

File > Export > GeoTIFF. Conserve les metadonnees geographiques.

File > Export View as Image. Resolution 300 DPI pour le rapport.



Bande

B1

B2 *

B3

B4 *

B5

B6

B7

B8 *

B8A

B9

B10

B11

B12
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Longueur d'onde (nm) Res. Usage

443 (Coastal) 60 m Aerosols

490 (Bleu) 10 m Scatter Plot, composites

560 (Vert) 10 m Composites RGB

665 (Rouge) 10 m Chlorophylle, NDVI

705 (Red-edge) 20 m Phenologie

740 (Red-edge) 20 m Phenologie

783 (Red-edge) 20 m Phenologie

842 (PIR) 10 m Structure foliaire, NDVI

865 (PIR etroit) 20 m Vegetation

940 (Vapeur eau) 60 m Atmospherique

1375 (Cirrus) 60 m Nuages

1610 (SWIR 1) 20 m Humidite, geologie

2190 (SWIR 2) 20 m Mineraux

* = bandes utilisees dans ce TP. Vert = 10 m | Blanc = 20 m/60 m

Figure 6 - Bandes spectrales Sentinel-2 MSI par resolution spatiale.
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Annexes

Annexe A : Les 13 bandes Sentinel-2 MSI
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Annexe C : Raccourcis SNAP

Annexe B : Glossaire terminologique

Raccourci

Terme correct

Matrice de radiance

Correction atmospherique

Reflectance de surface

Reeechantillonnage

Algebre de bandes

Acquisition / donnee

Action

Ouvrir un produit

Sauvegarder

Export GeoTIFF

Rafraichir

Zoom

Panoramique

A eviter

Image / photo

Nettoyage

Signal propre

Redimensionnement

Combinaison

Image satellite

Explication

Donnee quantitative calibree

Soustraction physique de L_atm

Grandeur sans dimension [0,1]

Interpolation geometrique

Operations matricielles pixel a pixel

Resultat de mesure calibree

F5

Ctrl+O

Ctrl+S

Molette

Ctrl+Shift+E

Clic molette + glisser




